Jump to Dashboard Option Not Showing

Comments

14 comments

  • Official comment
    Avatar
    Assaf Fraindlich (Edited )

    If you're not seeing the option then (with default JTD settings) you probably don't have a dashboard that begins with _drill that is based on the same cube.

    Verify that you have such a dashboard.

    If you wish to jump to a dashboard that is based on a different cube, then change the sameCubeRestriction setting in the config file to false. Note that only filters that are based on the same table name & same field name in both cubes will take effect (other will pass but won't have any effect - you can prevent those from passing by configuring the excludeFilterDims parameter)

    The config file is at C:\Program Files\Sisense\app\plugins\jumpToDashboard\js\config.js (for V7.2 & up)

    All configurations mentioned are also available at the widget level under edit script. Check out the JTD page (under technical details) for more information

    Comment actions Permalink
  • Avatar
    Evan York

    Did you just upgrade to v7.0?  I had a similar problem after upgrading and had to re-install the add-on from here (https://www.sisense.com/product/analyze/add-ons/) to fix it.  Works fine now.

    1
    Comment actions Permalink
  • Avatar
    Jignesh Pala

    Thanks Evan. I haven't updated to V7.0 yet. Weird thing is that I can see the drill and jump to dashboard options on some of the other dashboards but not on all. I haven't changed any settings either.

    0
    Comment actions Permalink
  • Avatar
    Malinda Jepsen

    Do you have any other JavaScript on the dashboards that aren't displaying the jump to option? It could be conflicting with the plugin.

    0
    Comment actions Permalink
  • Avatar
    Ok Ok

    Same here but i was already on 7.0 when installed jump to dashboard.

    I still can jump from dashboards where option was put, but the only thing i see in the options are 'edit script' and then 'delete dashboard'.

     

    Jump to dashboard mode simply disapeared.

    I don't remember having done anything special before it disapeared.

    I still can see the plugin installed in admin options.

     

    Thanks,

     

    T.L.

    0
    Comment actions Permalink
  • Avatar
    Ok Ok

    My mistake the option is to be seen once the widget opened.

     

    Thanks,

     

    T.L.

    0
    Comment actions Permalink
  • Avatar
    Cushrow Parakh

    I am having the same issue with Jump to Dashboard as the other users.  I downloaded the plugin script to the correct C drive folder, restarted the server, and I see the new plugin in the Admin tab of Sisense version 7.1.   

    My target dashboards have the requisite _drill_prefix but I just do not see any option to use Jump to Dashboard in any of my source widgets.  Only Save a Copy and Edit Script are available when I open the widget.  I also do not have any Java script on the dashboards.

    Please help!  Thank you.

    1
    Comment actions Permalink
  • Avatar
    Edgardo Gonzalez

    Target and source dashboard needs to have the prefix _drill_ in order to work. if only 1 dashboard has the prefix, it will not appear as an option in the edit options of the widget.

    0
    Comment actions Permalink
  • Avatar
    Chris Bridges

    Edgardo, I thought only the target dashboard had to have the prefix  _drill_ ? I've been having trouble recently where the option to jump to dashboard does not show up even though I have already set up the jump. Turning off the plugin in and turning back on seems to fix the problem but not a long term solution.

     

     

    I am using version 7.4.2.10063

    0
    Comment actions Permalink
  • Avatar
    Praveen Ramanathan

    Not seeing the option to jump to dashboard, I am using 7.4.2, tested on 7.1 also, but not working

    0
    Comment actions Permalink
  • Avatar
    Iris Maessen

    Are your jump dashboard and your main dashboard using the same data source? Especially with the later versions of the JTD plugin that seems to have become really important for the option to even show up in the menu.

    (If you want to jump from one data source to another, you can switch the datasource of the drill dashboard after assigning it).

     

    Iris

    1
    Comment actions Permalink
  • Avatar
    Andrew King

    I am seeing a similar issue, though we are using the folder prefix instead of the dashboard prefix.  In 7.0 a user with a designer role can see the option in edit mode, but in 7.2 and 7.4 they can't (the call to api/folders comes back empty).  If I try with my admin user it works correctly.  I haven't figured out a fix yet.

    1
    Comment actions Permalink
  • Avatar
    Tonya True

    I have a similar issue.  The dashboard currently has a jump too and is working, yet i have changed the jump to dashboard and need to point this to the new dashboard.  The jump too is no longer available for me to make this change.

     

     

    0
    Comment actions Permalink
  • Avatar
    Jonathan Sabah

    Thanks Assaf,

    The sameCubeRestriction option did the trick. It's easy to miss that at first.

    0
    Comment actions Permalink

Please sign in to leave a comment.