[ECM Error] Unable to connect to the specified file

Comments

6 comments

  • Avatar
    Nick Burleigh

    Hi Oxana,

    Thank you for posting this. This error is something that I have been struggling with for months. Since the usual format for Excel documents is xlsx these days, I'm probably not the only one. I think it would be helpful if you posted a note like this at the top of your "Preparing your Excel Files" and "Connecting to Microsoft Excel" pages (https://documentation.sisense.com/preparing-your-excel-files/ and https://documentation.sisense.com/introduction-to-data-sources/connect-to-microsoft-excel/), since people look at the documentation before the community posts.

    Best,

    Nick

    0
    Comment actions Permalink
  • Avatar
    Oxana Noa Umansky

    Thanks Nick, makes sense! I'll share your comment with our documentation manager. Will update you soon. 

    0
    Comment actions Permalink
  • Avatar
    James Monnier

    Is there no fix for this issue yet? We have had to go to office 365 and our files are failing with the Corrupted Open XML document error. I do not have the capability to save the files as XLS due to row count and we have about 1000 excel files  in our elasticube so converting them to CSV (in hopes that they don't fail importing due to special characters that may be in some of the text columns) and then going table by table to repoint to the csv vs excel files would be days worth of work even with a well written batch file. We have a ticket opened with support and have reached out to our CSM But I wanted to also post here for community help.

    1
    Comment actions Permalink
  • Avatar
    Brian Wilson

    In the same boat as James Monnier -- Hoping for a solution. Recent O365 convert as well, so maybe the format has changed slightly?

    0
    Comment actions Permalink
  • Avatar
    James Monnier

    We ended up moving to the latest version of Sisense and the issue was resolved. That being said though, there is a known issue with the most recent version where the cube does not see "Null" values correctly it sees them as ' ' blank. If you are not using "Is Null" statements in your lookups or anywhere in your elasti-cube this will not really impact you but you so, it may be better to wait until the next version comes out. That or you could go into your statements and add to look for is like ''  wherever you are looking for is null. If you need more explanation let me know here and I will try to follow up with you somehow as it took us a long time to figure this all out. 

    0
    Comment actions Permalink
  • Avatar
    Brian Wilson

    Thanks for the update James Monnier !

    We do use Null functions, so hopefully the new-new version is out soon. Appreciate the help

    0
    Comment actions Permalink

Please sign in to leave a comment.