Cors

Comments

1 comment

  • Avatar
    Moti Granovsky

    Hi Mario, I'm not sure this fully answers your question but if you'd like to allow CORS from all origins, you can use the following payload:

    {
    "webServer": {
    "cors": {
    "enabled": true,
    "allowedOrigins": [
    "*"
    ]
    }
    }
    }

    With the `POST /api/v1/settings/system` endpoint.

    You mentioned that since applying the invalid setting the API isn't working for you, if by that you mean it's not working at all and thus you cannot even apply the above settings, you can use Robomongo to access the MongoDB and update this bit manually to restore operation. It will be one of the documents in the `configurations` collection of the `prismWebDB` database (it contains a handful of documents, one of which will contain `webserver.cors`).

    2
    Comment actions Permalink

Please sign in to leave a comment.