Export Tables To CSV Post Plugin



  • Avatar
    Andrew Block

    I show both a ectools zip and an ectools_sisense_ver6.4 zip, I am assuming if we are on 6.4 or higher we would extract the 6.4 zip into C:\Program Files\Sisense\Prism?

  • Avatar
    Yoni Lerner

    For higher than 6.4 use ectools.zip 

  • Avatar
    Oxana Noa Umansky

    Hi Andrew,

    Thanks for your comment. To add to Yoni's reply and clear any confusion I've also updated the post (see at the beginning) with the following:

    Files included:

    • ectools.zip
    • ectools_sisense_ver<6.4.zip - (only for versions 6.4 and below)
    • python-2.7.11.amd64.msi
    • config_example.txt
    • EC_export.dll


  • Avatar
    Sonal Bansal

    We configured the above plug in and while executing the build , we are getting below error:

    Can you help me resolve this error?




  • Avatar
    Oxana Noa Umansky

    Hi Sonal,

    I'll create a support ticket for you, so that our team can investigate this issue. 

    You'll get a confirmation email with all the relevant information. You can also track any correspondence on this ticket via "My Activities". 



  • Avatar
    Maxim Havva

    Hi Oxana,

    Can you confirm if the plugin is working with the 7-th version of Sisense?

    I was using it successfully with older versions, but now on 7-th it says "failed to find the plugin"

    Have any dependencies changed?

    Just to clarify: all the contents of the ectools.zip is wrapped into "ectools" folder. I placed it into C:\Program Files\Sisense\Prism so the path looks like:

    C:\Program Files\Sisense\Prism\ectools\BuildTester\ ..



  • Avatar
    Maxim Havva

    Nevermind, I figured this out,

    best regards

  • Avatar
    Javier Irazazabal

    Hi all,

    Running the plugin, I'm getting an error: "Directory name not valid"

    I've tryed with several CSV's data target, but getting the same error.

    Do you have an idea about this issue cause?

    Thanks in advance!

  • Avatar
    Colton Porter

    I am getting the same issue. Can anyone help? 

  • Avatar
    Javier Irazazabal

    Colton Porter I have just solved it reviewing the installation files, to be sure that every file and folder should be located in the right place. Doing this, I put the plugin to work. Hope it helps

  • Avatar
    GEHC Large Dev

    Just to summarize the solution to the error "Directory name not valid" like it appears on the screenshots above. This error happens when the ectools folder is inside another ectools folder due to the unzip.

    To work the path should be C:\Program Files\Sisense\Prism\ectools\BuildTester\

  • Avatar
    Roopa Raghavan



    I tried working this today with a much smaller dataset just to get it working. I'm not sure what I am doing wrong, I don't see any CSV file in C:\data folder. The post execution plugin runs fine. The tables I'm trying to export to CVS format are SiteInfo and EnergyPoints which is given as 2 out of the 3 tables in the post execution plugin attributes. 

    Anyone that has got this working fine - any suggestions or obvious errors on what I'm doing wrong?


  • Avatar
    Elliott Herz


    I would try 1 table at a time. You can always add in multiple scripts in the post build plugin area that each just execute 1 table.



  • Avatar
    Roopa Raghavan

    @Elliott Thanks for your reply. Oleksandr from Sisense support worked with me today to help troubleshoot and turns out I hadn;t given the table names correctly. I had them as tables="table1, table2"

    2 mistakes there. The table names in my cube were dbo.table1, dbo.table2. Also in the plugin XML code, there should be no space between table names. Correcting both these helped solve the problem.

    My XML code ~

    <Attributes path="E:\data" csv="true" tables="dbo.EnergyPoints,dbo.SiteInfo" pythonPath="C:\Python27\python.exe" timestamp="true"></Attributes>

    If anyone is trying out this plugin, it works fine. Just be sure to follow and double check each step.




  • Avatar
    Ian Emmons

    I don't know if this will help anyone else, but I was unable to get this to work until I escaped the backslashes in my path.

    ie, changed path="C:\Sisense\BackupData\" to path="C:\\Sisense\\BackupData\\"

  • Avatar
    Denis Pesa

    Excellent plugin, I have installed it on Sisense 7.3 according to the instructions here and it worked perfectly. Thanks!

  • Avatar
    Andrew Block (Edited )

    Has anyone else ran into issues where the export works the first time then doesn't produce an output after that build? I have been seeing strange results from this. If I restart Sisense.ECMS and build again it works the first time and then after that build it no longer produces the csv file. I don't get an error for the plugin itself but get this message 

    2019-05-16 08:37:15,970 - INFO - Error: [Error 126] The specified module could not be found
    2019-05-16 08:37:15,971 - INFO - Will not perform data extraction from ECDATA, program will be terminated

    Here is a screenshot showing the plugin executed but it did not produce the output


    Here is the logfile from the succesfull one right before it

    2019-05-15 15:17:48,956 - INFO - ----------------------------------------
    2019-05-15 15:17:48,956 - INFO - 4.Creating tables from ECDATA and importing them into DB - starting time:2019-05-15 15:17:48.956000
    2019-05-15 15:17:48,957 - INFO - Creating Customers.csv ... (Customers)
    2019-05-15 15:17:58,905 - INFO - Creating Customers.csv created successfully!
    2019-05-15 15:17:58,905 - INFO - CSV files creation ended at: 2019-05-15 15:17:58.906000

    Would love for this to work without having to restart services each time, has anyone else experienced this or have a workaround?


Please sign in to leave a comment.