Adding Logo/Image to a dashboard

Comments

74 comments

  • Avatar
    Erin Frazer (Edited )

    Hi Ronen, 

    Does that mean we have to re-link every picture in dashboards? We are having too many pictures. Is it any way that we don't have to do it again?

    And also, will the link work with sub-folder of 'resources' ?

    Thank you.

    2
    Comment actions Permalink
  • Avatar
    Tommy

    For versions V7.1.3 and lower, you can create images and add them to your web directory, so you don't have to reference an image that's already online. Just follow these steps:

    1. Create the image you'd like to use, and save it on the machine that's hosting the web server

    2. Open IIS, open the Sites folder on the right, right-click SiSenseWeb, and select 'Add Virtual Directory'

    add_virtual.JPG

    3. Create any alias you'd like for this new directory, and then make the physical path the folder that contains the image you'd like to use.

    virtual_deets.JPG

    4. Right click on the virtual directory in the left pane of IIS, click Edit Permissions..., and go to the Sharing Tab of the security menu. Click the  "Share..." button, and in the drop down menu of who to share with, select Everyone, and give them Read access

    Sharing.JPG

     

    5. Open cmd as administrator, and run iisreset

    6. You will now be able to access this image from your browser. You'll go to the <SiSense host URL>/<virtual directory name>/<image name>

    test_image.JPG

     

    1
    Comment actions Permalink
  • Avatar
    Philip Lima

    Problem solved. You need to make sure the folder is named just "imageWidget" since there is a hard-coded reference to the folder name in the widget. In the current version that is posted, the folder is named "imageWidget_05_13_2016"

    Once you unzip this and place it in the plugins folder, remove the date portion of the folder name "_05_13_2016" and you'll be all set.

    1
    Comment actions Permalink
  • Avatar
    Yoni Lerner

    Hi Sai,

    Sisense uses Prismweb directory as a "Home page" meaning that if you wish to get a file from there like in your case the path you need is only \webimages\name of file

    I Prefer to put all images in the Resources\Images folder I created so it will look like this

    Hope that helps.

    1
    Comment actions Permalink
  • Avatar
    Alexandre Biton

    Hello all, 

     

    Anybody had trouble exporting pdf with the latest version of this plugin ? 

    Our organization can't export pdf with image widget anymore and neither iis reset nor installation repair is fixing this issue. Waiting for the next update. 

    PS : We are working with V7.1

    Thanks for your help. 

     

    Regards, 

     

    Alex. 

    1
    Comment actions Permalink
  • Avatar
    Li Li

    Hi, All,

    I had this plugin working fine with 7.0, using IIS virtual directory as instructed by the 2nd comment of this thread. I just upgraded Sisense to the latest 7.2 a few days ago, and now the logo images are no longer showing. It appears NodeJS has changed the virtually directory behavior, as when I try to access the image address from a browser, it doesn't display the image, instead it displays "api not found". Any ideas?

    Thanks,
    -Li

    1
    Comment actions Permalink
  • Avatar
    Roopa Raghavan

    broken image icon while using this plugin. We have Sisense version 7.2 and I have the plugin in Sisense/app/plugins folder and the images in Sisense/app/resources/Images folder.

    I have re-downloaded plugin, restarted IIS and my dashboard still won't display the image. It shows fine in the browser.

    Anyone else facing this issue? I'd appreciate any help or suggestion. Thanks!

    1
    Comment actions Permalink
  • Avatar
    James Monnier

    Did you try entering the path in the widget as /resources/imagename

     

    i.e. /resources/Logo1.jpg

    1
    Comment actions Permalink
  • Avatar
    Alon Ahronberg

    Another good use for the image plugin is using it as a header. Let’s say you want to divide the dashboard into sections, and add headers accordingly. Simply add a new image widget, set it’s title and click “apply”.

    All that is left is to minimize the size of the widget and place it in the proper place.

    In addition, You may also change the background color of the image.  In the example below the headlines are marked in blue.

    0
    Comment actions Permalink
  • Avatar
    Alon Ahronberg

    Plugin updated to work with v5.7.5, if you used the previous plugin version, images wont be shown and "no results" image appears. To adjust it, simply  overwrite the previous version with the one attached to this forum.

    0
    Comment actions Permalink
  • Avatar
    Sinu Joseph

    Is there a property that I can set so that the image size increases or reduces in proportion whenever the resolution of the window changes?

    0
    Comment actions Permalink
  • Avatar
    Joseph Peters

    I can't get this plug in to work with version 5.7.5 even after replacing the folder with the new one.  I get an empty box.  See attached image.  I deleted the old folder and copied over the new folder.  Also, my old images are now empty widgets that apparently cannot be deleted or edited.

     

     




    ImageWidget.png
    0
    Comment actions Permalink
  • Avatar
    Michael Becker

    Joseph, new Image does not use widget title as image reference anymore. In the Design section you have a separate box to specify image location.

    0
    Comment actions Permalink
  • Avatar
    Joseph Peters

    Hey Michal, thanks for the response.  I dont see that option in my window.  I've tried deleting the plugin folder, resetting iis, extracting new folder, resetting iis again, creating new dashboard and new widget but it isn't working.  I've attached an image of the blank design pane.




    ImageWidget2.png
    0
    Comment actions Permalink
  • Avatar
    Michael Becker

    Does it happen when you add a completely new image as well? It may be that previous configuration does not work with new one and you'd need to delete each image and create it from start.

    0
    Comment actions Permalink
  • Avatar
    Joseph Peters

    Yes, it happens when I create a new widget in a whole new dashboard.

     

    0
    Comment actions Permalink
  • Avatar
    Sinu Joseph

    Hi, 

    i'm using the latest version of sisense, 5.7.5 i've updated the widget in the plugins and restarted IIS. I'm getting blank for image. This feature is necessary since i'm using this in almost all the dashboards.

    0
    Comment actions Permalink
  • Avatar
    Sinu Joseph

    works perfect now.. my bad. I kept both Old and new widget folder in the same plugin folder which was creating Multiple Directive error.

    0
    Comment actions Permalink
  • Avatar
    Robert

    Does the image widget  work with version 5.8?

    0
    Comment actions Permalink
  • Avatar
    Alon Ahronberg

    Hi Robert,

    Yes it should.

     

     

    0
    Comment actions Permalink
  • Avatar
    Atad

    Hi all.

    I can't get the plugin to work properly. I've installed it and when I place a link to a shared picture I always get a "broken image" icon instead of the picture I try to add (see attached screenshot). I'd appreciate any advice with this problem. Thanks.




    imageWidgetScreenshot.png
    0
    Comment actions Permalink
  • Avatar
    Inbal

    Hi Atad,

    I see the link is from a Google Drive account. It's probably an authorization problem.

    Please try to download the picture and add it to a virtual directory (follow Thomas explanation in the comments).

    Best,
    Inbal

    0
    Comment actions Permalink
  • Avatar
    guy

    Hi,

    I also get a 'broken image' icon. I've downloaded the picture and added it to a virtual directory and am able to view the image in a browser. I'd appreciate any advice with this problem. 

    Many thanks

    0
    Comment actions Permalink
  • Avatar
    Michael Becker

    @guy - try removing broken image widget, then download the plugin again and save it again to plugins folder. Sometime widget breaks (especially when upgrading SiSense)and I found this way to fix it. Hope it helps.

    0
    Comment actions Permalink
  • Avatar
    Michael Becker

    It seems that this plugin stopped working on Firefox. I'm getting broken image constantly now.

    0
    Comment actions Permalink
  • Avatar
    Sergio Alvarez

    I have the same issue as Sinu

    "Is there a property that I can set so that the image size increases or reduces in proportion whenever the resolution of the window changes?"

    0
    Comment actions Permalink
  • Avatar
    Simon Vosloo

    Hi

    I see Sinu had the same question I had, but no response about it.

    Is there a way to ensure that the aspect ratio is maintained. Any other suggestions on how we can include client logos etc also welcome

    0
    Comment actions Permalink
  • Avatar
    Sinu Joseph

    Hi Sergio & Simon, 

          The only way i could see is, you can set the width and height of this particular widget. Please use the below code. Place this in the script screen of the widget.  Change the height and width according to the aspect ratio of the image you're trying to display.

    widget.on('ready', function(se, ev){
    $(element).css('height','130px'); //changes the widget's image height
    $(element).css('width','350px'); //changes the widget's image width
    })

    0
    Comment actions Permalink
  • Avatar
    Simon Vosloo

    Hi Sinu

    Thank you for the help.

    How would one go about center aligning the image though? Is this possible.

    I tried $(element).css('align','center'); But that did not seem to work

    0
    Comment actions Permalink
  • Avatar
    Mark Shear

    Is this working in the newest version of sisense? I now get a broken link on my image even though ive checked everything.

    0
    Comment actions Permalink

Please sign in to leave a comment.