The Smart Label

Comments

105 comments

  • Avatar
    Sergey Borodich

    Following up - anyone else has PDF export error with this plugin? It fails with "- widget type:smartLabel it not registered.

    Maybe there's a way to bypass this?

     

    0
    Comment actions Permalink
  • Avatar
    Avi Tavdi

    @Sergey - that mean that you had a smartLabel widget and now it does not exist anymore, please make sure the smartLabel plugin exist in your plugins folder located at prismweb/plugins.

    0
    Comment actions Permalink
  • Avatar
    Sergey Borodich

    @Avi, all files are there, but I still get this error, tried restarting IIS - no luck.

    Is there anything I can do to "reregister" it?

    Thanks!

    1
    Comment actions Permalink
  • Avatar
    Lee

    @Sergey - After you've made sure that the smartlabel library exists in C:\Program files\Sisense\Prismweb\plugins and restarting IIS, canclear browser cache and refresh browser?

    0
    Comment actions Permalink
  • Avatar
    Sergey Borodich (Edited )

    @Lee, yep, even restarted Sisense server and cleared Google Chrome cache and local storage, widget works fine but PDF exports fails....

    0
    Comment actions Permalink
  • Avatar
    Lee

    @Sergey This sounds like an IIS issue or in configuration, please see this guide and open a ticket with support if it doesn't help

    0
    Comment actions Permalink
  • Avatar
    Nick Bernini

    Using Sisense 6.4 and this plugin is working fine.  However, if I have 2 filters on the dashboard and one is dependent of another, then this widget shows no data.  Is it possible to have this plugin work for dependent filters as well?  Ultimately, my users will have a set of dependent filters like Brand->Category, and then a 3rd filter, say Month, that is not dependent.  We would like all 3 of these filters to be able to be displayed in the widget.

    1
    Comment actions Permalink
  • Avatar
    Joel Baynes

    @Nick facing the exact same problem. If you achieved any work around yet?

    0
    Comment actions Permalink
  • Avatar
    Yoav

    @Nick and @Joel

    Unfortunately the plugin today does not support dependent filters, only regular ones.

    0
    Comment actions Permalink
  • Avatar
    Praveen Prabhu

    Hi ,

     

    I need a help regarding smart label. Earlier the plugin used to accept multiple dimensions in the same widget. But after the update, it shows only one dimension, also we cannot show the dimension name in the widget. please look into the below screenshot - 
    find the below

    0
    Comment actions Permalink
  • Avatar
    Michael Becker

    @Praveen - ensure you've downloaded the version from 28th of October. It should solve this issue. 

    0
    Comment actions Permalink
  • Avatar
    Malinda Jepsen (Edited )

    In 6.4.2.11006, I'm having an issue with the Smart Label putting a comma just before my text.  When I installed the newer version, I had to go turn off the labels and then it displayed a comma instead of the label.  Has anyone else seen this and any ideas on how to fix it? (using the October version of the plugin)

    0
    Comment actions Permalink
  • Avatar
    Omer

     

    @Malinda - I would need you to further elaborate on your case. I think it would be best if you submit a ticket on this with the whole details of the issue (screenshots are welcome as well).

    Thanks,

    Omer

    0
    Comment actions Permalink
  • Avatar
    Malinda Jepsen

    Thanks.  I will do that.

    0
    Comment actions Permalink
  • Avatar
    Malinda Jepsen

    As an update to my leading comma issue:  I was able to figure it out.  I had more than one row returning data for that SmartLabel.  Once I added a filter to it to ensure it would only display one value, the comma disappeared.  

    1
    Comment actions Permalink
  • Avatar
    Jon Wrye

    Access to the plugin is restricted now? Was this intentional? Just trying to update our existing plugin and can no longer download it freely. I requested access - how long will it take to be granted?

    0
    Comment actions Permalink
  • Avatar
    Oxana Noa Umansky

    Hi Jon,

    I'm looking into this and will update you shortly. 

    Thanks,

    Oxana

    0
    Comment actions Permalink
  • Avatar
    Oxana Noa Umansky

    Jon and all, you should have access to the file again. Please let me know otherwise. 

    -Oxana

    0
    Comment actions Permalink
  • Avatar
    Jon Wrye

    Thank you Oxana! I appreciate the quick response.

    0
    Comment actions Permalink
  • Avatar
    Erik Pfalzer

    Any plans to allow this to work when dependent filters are used? 

    0
    Comment actions Permalink
  • Avatar
    Jim Thomas

    i'm having issues with the latest version on both v6.5.2.10062 and the v6.6 beta (6.6.0.2). It doesn't seem to work well on v6.6. Existing widgets have to be recreated to function. Doesn't seem to work at all on v6.5. Currently using the Feb. 3 version with v6.5 and it works fine.

    0
    Comment actions Permalink
  • Avatar
    Leslie Ambrose

    It appears that the field name is not included in the label in Sisense 6.5.0.15.  On our older system, we see both. Is this a change or am I just missing the configuration option?  

     

    0
    Comment actions Permalink
  • Avatar
    Omer

    Hi Leslie, 

    This is not a change and shouldn't be happening. 

    Are you using any scripts in the widget/dashboard which might affect this?

     

    Regards,

    Omer

    0
    Comment actions Permalink
  • Avatar
    bob vecchione (Edited )

    How can I remove or change the COLON   : Following the column name?   Region:  Northeast

     

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Leslie Ambrose

    Hi, Omer,

    Sorry to be slow in responding!  I didn't see your comment.  No, there are no scripts.  

    Looking again at the pictures in the description of this plugin at the top of this page, I see both behaviors.  The circled "United Kingdom" data matches what I'm seeing in our 6.05 system.  The label above the world map appears to have labels.

    My example used just the Sample ECommerce dashboard that was provided above.  I tried it on one of our systems with Sisense 6.02.something and again on 6.05.0.15.  On the 6.05 version, the label "Country: " does not appear.  On the lower release, I could see both the name of the field supplied for TEST and the actual value, as shown below.  

    Thanks,

    Leslie

    0
    Comment actions Permalink
  • Avatar
    Yoni Lerner

    Hi Leslie,

    You can modify Widget.js file in the plugin changing 

    labelName = this.labelName + ': '

    to labelName = this.labelName + ' ';

    0
    Comment actions Permalink
  • Avatar
    BI Reporting

    Latest Version Mar 8th 2017, is not allowing dependent filters work. Do you have latest version by any chance?

    0
    Comment actions Permalink
  • Avatar
    Evgeni Rovinsky (Edited )

    Attached the latest version of the plugin, that supports dependent filters (tested on 6.6.0.10328).

    You can download it from here.

    Also added a link at the top of the page.

    0
    Comment actions Permalink
  • Avatar
    Jim Thomas

    Evgeni,

    This dependant filters update is really nice.  Thank you.  

    The SmartLabel has an issue on v6.6 with dashboard that have SmartLabel widgets from v6.4/v6.5.  When a server is upgraded from the older version to v6.6 or dashboards are imported from the older version the SmartLabel does not fuction.  In fact, you have to either delete the widget and recreate or open the widget and change to another widget type and then back to SmartLabel and reconfigure.  The error that I see is that the SmartLabel is not registered which I would normally see if the plugin was not installed.  I'm wondering if somehow in these updates the name is changed from the older versions such that the newer plugin versions don't recognize the old widgets?

    We use the SmartLabel extensively and want to upgrade to v6.6 soon, but can't until this issue is resolved.  I actually have a ticket in on this (#39376).  Would love it if you could solve this for us.

    Regards, Jim

    0
    Comment actions Permalink
  • Avatar
    Evgeni Rovinsky

    Hi Jim,

    Can you please send me the version of the plugin, you are using ?

    Thanks.

    0
    Comment actions Permalink

Please sign in to leave a comment.