Custom Map Widget

Comments

41 comments

  • Avatar
    Tripti Jaiswal

    Plugin is not working as expected in Version: 8.1.1.10190.

    Using the Elasticube in ticket for testing purpose.

    2
    Comment actions Permalink
  • Avatar
    Ido Darnell

    Hi All,

    Glad to announce we've developed a few advanced maps based off of Deck.gl for visualisations of large data sets,

    With these maps you can tailor suit your specifications onto any available layer, as well as combine a few layers to further enhance your mapping requirements:

    - Deck.gl QBeeQ Plugin

    - Advanced Google Heat Map

    More to come soon!

    Feel free to reach out for a live demo,

    info@qbeeq.pl

    www.qbeeq.pl

    Sisense QBeeQ Partner Page

    Sisense Partner of the Year 2019!

    0
    Comment actions Permalink
  • Avatar
    Brian Wilson

    Echoing Tripti Jaiswal -- Not working in 8.1.1

    0
    Comment actions Permalink
  • Avatar
    steve w

    Figured out issue in 8.1.1. the json load was failing. need to un-comment the dataType and set to "jsonp"

    var request = $.ajax({
    type: "GET",
    url: selectedMapType ? selectedMapType.url : '',
    contentType: 'text/json;charset=UTF-8',
    dataType: "jsonp",
    async: false

    JSONP is used to bypass the Cross-Domain Request boundaries, under which the scripts that run on one domain are restricted to access the data from another page on different domain.

    Apparently, 8.1.1 affected the boundaries as it pertains to this plug-in loading the data. 

    3
    Comment actions Permalink
  • Avatar
    Brian Wilson (Edited )

    Thanks steve w !

    Confirming that editing widget.js line 188 as you detailed fixed the issue.

    1
    Comment actions Permalink
  • Avatar
    Ganesan Kanavathy

    Hi I am new to this widget with 0 knowledge in javascript and GeoJSON.

    I am trying to implement this widget for a dashboard in our organization. we are based in Malaysia. How can I display map for Malaysia based on our GPS Coordinates. I can see only options of Canada, US and China Province.

    Please advise..

    0
    Comment actions Permalink
  • Avatar
    Abbe Lefkowitz

    Hello

    I have added Nielsen DMA info to the map config.js file with keyAttribute dma_name, and I have the new Nielsen Map selected in the Map Types. I have included dma_name field in my dataset and placed it in the geography bucket and aggregated value in the Value bucket, but nothing shows up on the map visualization. Please help!

    0
    Comment actions Permalink
  • Avatar
    Tyler Smith

    We recently updated to 8.2.1.366 and the maps using this widget all failed to load. I tried the change steve winkiel suggested and it now displays the shapes but the map doesn't load. So I get the shapes on a grey background.

    The error was:

    Refused to load the image '<URL>' because it violates the following Content Security Policy directive: "img-src 'self' data: a.tiles.mapbox.com b.tiles.mapbox.com c.tiles.mapbox.com".

     

    0
    Comment actions Permalink
  • Avatar
    Artem Yevtushenko (Edited )

    Tyler Smith please make sure you whitelist any external URLs in security settings.

    https://documentation.sisense.com/latest/administration/defining-security-and-access-settings/security-hardening.htm#gsc.tab=0

    0
    Comment actions Permalink
  • Avatar
    Tyler Smith

    Artem Yevtushenko, thanks for your response, but I'm not viewing this via an embedded site. I am viewing this in Sisense proper. According to the documentation the white listing is for embedded instances so I fail to see how it applies. Unless you mean to whitelist the mapbox site, but I'm not embedding there. I tried added it anyway, but it didn't do anything.

    It also occurs to me that it might be worth point out that I'm on the Linux version and not windows. 

    0
    Comment actions Permalink
  • Avatar
    Vlad Cimpan

    Hi,

    I'm trying to use this widget. MapBox has upgraded to V4 though, while this widget seems to have been built on V3. It doesn't look like it's picking up the API key correctly in the calls, some of the parameters have changed names from the example config file given here. So I'm not able to get any render back at the moment.

    Can anyone help making this work with MapBox V4 API?

    Thanks

     

    0
    Comment actions Permalink

Please sign in to leave a comment.