Pivot Widgets 'collapsed' until page is refreshed



  • Avatar
    Andrew Block

    Troy have you tried using a different browser such as IE or Mozilla to see if it occurs on that browser as well?

    We are experiencing something similar but not exactly the same where pivot tables don't expand their full width unless you refresh the page or expand the pivot and close out....but the issue only affects Chrome, which is what we have all of our users using for browser

  • Avatar
    Troy Griffin

    Hi Andrew, and thanks.

    It does seem to work better in Firefox, but that browser is not supported by our proprietary software -

    I do have an 'empty' widget that I can't edit or delete - I suspect this may be causing issues as well. Any thoughts on how to remove an empty widget?

    Thanks again,


  • Avatar
    Andrew Block


    Have you checked in your MongoDB to see if that 'ghost' widget exists in the "widgets" collection?

  • Avatar
    Troy Griffin

    well, great idea, but I'm not quite sure how to do that - totally Unfamiliar with MongoDB

  • Avatar
    Andrew Block


    First you will need to download an IDE for your MongoDB, I use RoboMongo (link at bottom).

    Next you will need to create an application database user and connect to the application database, you can use the following documentation that does a good job explaining:


    After that is setup you will need to connect to MongoDB and go to your 'widget' collection, which is the repsository for all the widgets you have (screenshot attached)


    Next you will want to find the objectID of the ghost widget

    • You can do this by clicking edit on the ghost widget and coping the ID that comes after widgets/


    Once you have this id you will want to use the below search in RoboMongo and replace the ID i have with your ghost widget ID:

    db.getCollection('widgets').find({"oid" : ObjectId("5ac5265ad88e0e396f32e93f")}) //

    Once you hit the run button it should find the record and you will need to delete it:

    Delete by right clicking on the ObjectID and click "Delete Document"

    Then go back in and reload your dashboard and see if it is still there

    Let me know if this works for you



    RoboMongo link


  • Avatar
    Brian Wilson

    Hey Troy,

    I've had some odd issues with the Tabber along the way too. Great feature, but it's touchy.

    If Andrew's walkthrough isn't working, I've had success with downloading the dashboard itself, editing it in a text editor and then re-uploading it. Often you can find the code with the "ghost" widget, delete it, save it and put it right back in the spot.

    From the dashboard sidebar, make a copy of your dashboard and then right click > Export. When you find the .dash file in your downloads, you can right click > open with Notepad (Or Notepad++ or other coding-specific text editor)

    Search for "Yearly overview by department" and that should get you around the right section of the problem. Look around and see if you notice any code related to old widgets.. maybe missing a title or datasource. You can delete that code save as a dash and re-upload (Import Dashboard at the top of the sidebar)






  • Avatar
    Cushrow Parakh

    We are having the same issues as Troy referred to regarding collapsed widgets with version and Chrome.  We are not able to delete, edit, or copy them and we've tried restarting the Sisense server and refreshing the dashboards but nothing seems to work and we have had to recreate the dashboards from scratch.

    I've been working with Sisense for about three months and yesterday was the third instance of this occurrence.   I have not tried the MongoDB solution referenced above.

Please sign in to leave a comment.