Redshift Query Timeout - How to increase Receive Timeout on the connection

Comments

2 comments

  • Avatar
    Michael Guidone

    As it turns out, there is an XML configuration file for the Redshift connector at:

    C:\Program Files\Sisense\DataConnectors\DotNetContainer\Connectors\Redshift\Sisense.Connectors.RedshiftConnector.dll.config.

    It has a section:

    <RedshiftSettings> 
    <!-- 
    The time to wait (in seconds) while trying to execute a command before terminating the attempt and generating an error. 
    Use 0 for infinity. 
    --> 
    <add key="Timeout" value="0" /> 
    </RedshiftSettings> 

     

    It took a long shot guess and assume that these keys corresponded to items on the connection configuration and added the following.

    <add key="Command Timeout" value="0" /> 

     

    And this worked for me!

    The difference is the Timeout is setting the connection timeout, and Command Timeout sets the timeout on the query (or the socket stream receive to be more accurate).   

    0
    Comment actions Permalink
  • Avatar
    Michael Guidone

    We may NOT want to share this as a success. Turns out that the only reason it worked is that I had recently done a query using that view and the data was cached for Sisense when the build ran.

    So I do not think setting that key actually set the underlying "Command Timeout" on the connection. I still need a solution for this. 

    0
    Comment actions Permalink

Please sign in to leave a comment.