7.2 SSL Connect to local Elasticube from Elasticube Manager

Comments

3 comments

  • Avatar
    Logan Grieser

    Same issue here, broke after the 7.2 update with SSL

    0
    Comment actions Permalink
  • Avatar
    Thomas Rippon (Edited )

    Same issue here. The "Sisense ElastiCube Connector" and the documentation for importing elasticube data, https://documentation.sisense.com/latest/managing-data/connectors/sisense-elasticube.htm, is not clear what is meant by "database server location", "address of your elasticube", or "the port you changed" (there are many ports that can be changed??). Best guess is "Gateway service" was intended here, according to https://documentation.sisense.com/latest/getting-started/communication-ports.htm and the reference to port 8081.

    I worked around the issue by disabling SSL on Sisense, and adding an SSL-enabled reverse proxy server to Sisense services.  Here are the steps I used, though IIS can be used in place of nginx:

    1. Disable SSL on Sisense and move Sisense gateway to a private port, e.g. 12345
    2. Install nginx
    3. Configure nginx to forward requests to Sisense gateway (sample configuration below)
    4. Configure SSL on nginx
    5. Wrap nginx into a windows service (via winsw, for example)

     

    Sample nginx configuration:

    server {
    listen 443 ssl;
    server_name data.example.com;

    ssl_certificate /path/to/cert.crt;
    ssl_certificate_key /path/to/cert.pem;

    location / {
    proxy_pass http://data.example.com:12345/; # hosts file maps FQDN to 127.0.0.1

    proxy_http_version 1.1;
    proxy_redirect off;
    proxy_set_header Host $host;
    proxy_set_header X-Forwarded-Proto $scheme;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Host $server_name;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
    }
    }
    0
    Comment actions Permalink
  • Avatar
    Hamza Jap-Tjong

    Hey,

     

    I had the same issue and contacted support. Afterwards I received some files which I needed to add to my Sisense directory. Doing this enabled the EC2EC-connector on SSL without any problems

    0
    Comment actions Permalink

Please sign in to leave a comment.