YTD SUM not working correctly?

Comments

4 comments

  • Avatar
    David Hertzberg

    Hi Hamza,

    Have you tried with an IF formula? The problem probably comes from the fact the two missing categories have null values in december.

    You can try a formula like : IF ( ISNULL( SUM(Measure) ), 0, SUM(Measure))

    Let me know how it works, and if support sees that as a bug or normal behaviour. For instance, in continuous time series, you have the option the ask sisense to consider null values as 0 (see https://documentation.sisense.com/latest/creating-dashboards/additional-widget-designs/create-continuous-chart.htm).

    Best,

    David.

    0
    Comment actions Permalink
  • Avatar
    Hamza Jap-Tjong

    Hi David,

     

    Thanks for the tips. Unfortunately both options were not able to fix the problem. The dip remains 

    0
    Comment actions Permalink
  • Avatar
    David Hertzberg

    Then you could try in the elasticube : to be sure you get a 0 instead of null. Ultimately you can use a Javascript to do the running sum by script. I use that kind of script for inverse running sum. I can look in my archive if you want.

    Best,
    David

    0
    Comment actions Permalink
  • Avatar
    Hamza Jap-Tjong

    Hi David,

     

    If you could fine the javascript for me that would be great. The way our elasticube is designed , your suggestion would not be the best solution

    0
    Comment actions Permalink

Please sign in to leave a comment.