Actual implementation of "Jump to Dashboard"

Comments

17 comments

  • Official comment
    Avatar
    Adi Lewenstein

    Hi Hendrik!

    Please note that the Jump to Dashboard display arguments (displayDashboardPane and displayFilterPane) should be nested under a data property named args:

    {
    "type": "JTD",
    "title": "Jump To Dashboard",
    "data": {
    "dashboardId": "5ccbb5da5075550e44c99f32",
       "args":{

               "displayDashboardsPane": false,
               "displayFilterPane": true

       }
    }

    In addition, please make sure that you are using the very latest version of Jump to Dashboard, released after April 4th.

    Let me know if that helps!

    Comment actions Permalink
  • Avatar
    Hendrik Venter

    Hi Adi

    Thanks so much for the input. I've downloaded all the latest components of the Blox widget as well as Jump to Dashboard. So I got it working by adding the args as pointed out. I have a couple more questions if that's ok:

    Is it possible to have a button to navigate from the current dashboard to the next? The JTD opens in "lightbox" mode, and this code opens a new tab in Chrome:

    "type": "Action.OpenUrl",
    "title": "Open In Web",
    "url": "https:/{server}.sisense.com/app/main#/dashboards/5ccbb5da5075550e44c99f32/"

    Thanks,

    Hendrik

    0
    Comment actions Permalink
  • Avatar
    Adi Lewenstein (Edited )

    Hi Hendrik!

    Jump to Dashboard indeed supports same-tab navigation by setting the drilledDashboardDisplayType property to "3" (please make sure to include the apostrophes since the plugin expects a string).

     

    To set this definition specifically to a specific action, please add the following attribute to the arg:

    {
       "type": "JTD",
       "title": "Jump To Dashbaord",
       "data": {
          "dashboardId": "5ccbb5da5075550e44c99f32",
           "args": {
             "displayDashboardsPane": false,
             "displayFilterPane": true,
             "drilledDashboardDisplayType": "3"
       }
    }
     
     
    If you would like to change the Jump to behavior across the system, I'd recommend setting the display type to 3 in the Jump to Dashboard config file, as described in the Jump to Dashboard documentation.
     
    0
    Comment actions Permalink
  • Avatar
    Hendrik Venter

    Hi Adi

    Thanks for the feedback - much appreciated.

    I'm however not able to get consistent behaviour with this - putting the args "drilledDashbboardDisplayType" to 3 results in a new tab opened. Perhaps there is other code somewhere influencing the behaviour.

    I'm not from a programming background and have a session with a Sisense BI consultant next week - I've got a long list of dashboard/formatting related questions and I'll add this one to it.

    0
    Comment actions Permalink
  • Avatar
    Vikas Sharma

    When i am  trying to paste this JTD code in the blox widget then button is not appearing, Please suggest what can be the reason?

    0
    Comment actions Permalink
  • Avatar
    Ron Oren

    Hi Vikas,

    Please make sure to use the code above under the actions area, like this >>

     

    "actions": [
    {
    "type": "JTD",
    "title": "Jump To Dashboard",
    "data": {
    "dashboardId": "5ccbb5da5075550e44c99f32",
    "args": {
    "displayDashboardsPane": false,
    "displayFilterPane": true
    }
    }
    }]}
     
     
    Also, make sure that Jump to dashboard plugin is installed on your machine.
     
     
    0
    Comment actions Permalink
  • Avatar
    Adi Lewenstein

    Hi Vikas,

    Can you please make sure that the action is pasted within one of the following elements:

    1. The main BloX object's actions array

    2. An action set within the BloX body

    3. Another element's selectAction attribute

    0
    Comment actions Permalink
  • Avatar
    Adi Lewenstein

    Hendrik,

    Can you please move the drilledDashboardDisplayType to be the first attribute of the args object?

    It seems to work for me, though we are still investigating why. 

    {
       "type": "JTD",
       "title": "Jump To Dashbaord",
       "data": {
          "dashboardId": "5ccbb5da5075550e44c99f32",
           "args": {
             "drilledDashboardDisplayType": "3",
             "displayDashboardsPane": false,
             "displayFilterPane": true
             
       }
    }
    0
    Comment actions Permalink
  • Avatar
    Hendrik Venter (Edited )

    Thanks Adi.

    I've tried your suggestion by moving it first, however I still get range of behaviour - sometimes it will open in popup mode, other times in a new tab. I've selected the "DisplayType" as 2 (popup). In addition, I'm struggling with default filters on the destination dashboard not resetting.

    Feels like the widget needs some development and stabilisation. In order to get this in a working state I'll revert back to the indicator / drill type widgets for now.

    Thanks anyway
    Regards
    Hendrik

     

    0
    Comment actions Permalink
  • Avatar
    David Oyler

    Adi;

    Was anything ever found for this? I am experiencing the same issue. Setting the drilledDashboardDisplayType to 3 doesnt make a difference, it still opens in a new tab.

     

    "selectAction": {
    "type": "JTD",
    "title": "Jump To Dashboard",
    "data": {
    "dashboardId": "5d0b7cf966b6521b2c6676f1",
    "args": {
    "drilledDashboardDisplayType": "3",
    "displayDashboardsPane": false,
    "displayFilterPane": false,
    "displayToolbarRow": false,
    "displayHeaderRow": false
    }
    }
    }
    0
    Comment actions Permalink
  • Avatar
    Adi Lewenstein

    Hi guys,

    Seems that the drilledDashboardDisplayType is an attribute that JTD reads from the entire widget level, and our action level definition was overridden.

    As the quickest resolution, try defining this specific attribute on the widget script like you would for any other widget type:

    prism.jumpToDashboard(widget, { "drilledDashboardDisplayType": 3});

    0
    Comment actions Permalink
  • Avatar
    Rob Warner

    Hi all,

    We're getting up to speed on BloX and have recently updated our jump to dashboard plug in to add BloX support.  After the plugin update it appears that the displayFilterPane parameter isn't working for non-BloX indicator widgets.  

    Here is a script example we're using:

    prism.jumpToDashboard(widget, {
    drilledDashboardDisplayType:2,
    displayFilterPane:true,
    excludeFilterDims:["[1-Site.state_province]","[1-Site.Chain]","[1-Site.Region]","[1-Site.Display_Name]","[3-RTU_EquipData.Service Area]"],
    displayDashboardsPane:false,
    displayToolbarRow:false,
    displayHeaderRow:false,
    drillToDashboardNavigateType:1,
    dashboardId:"5ce199c4adcb022d204784f5"
    });

    With this script the filter pane is not appearing in the jumped to dashboard - with the jump to dashboard plugin updated to the latest version does this script need to be updated to get the displayFilterPane parameter to work?

    Thanks!  

    0
    Comment actions Permalink
  • Avatar
    Adi Lewenstein

    Hi Rob,

    I'm afraid I couldn't reproduce the issue.

    I copied your script to an indicator widget on my local environment (minus the dashboard ID and exclude filters properties, which are specific to your environment) and was able to successfully control the displayFilterPane attribute.

    the BloX-related changes in the jump to dashboard plugin were not supposed to affect any existing config properties or other widget types. 

    Will you please be able to contact Support with this issue?

     

    Thanks,

    Adi

    0
    Comment actions Permalink
  • Avatar
    Akshay Rao

    Hi Adi,

     

    Can you please tell me where can I find the dashboard ID

    and instead of dashboard ID can i pass Dashboard URL ?

    best 

    Akshay Rao

    0
    Comment actions Permalink
  • Avatar
    David Oyler

    Akshay - if you open a dashboard, the ID is in the URL:

    https://myserver.mydomain.com/app/main#/dashboards/5d40255509506615b8d8d6ee/

    The value: 5d40255509506615b8d8d6ee is the dashboard ID.

    If you are referring to the Blox action of JTD, then I'm unsure of using a URL to pass for the JTD, but I kind of doubt it. I havent actually tried it...

    0
    Comment actions Permalink
  • Avatar
    Akshay Rao

    Thanks David.

     

    No, I am not trying to use blox, I just need the basic JTD functionality.

    I followed every step in tech details but unable to find the jump to dashboard option in the widget setting, So I was wondering if it is  achievable by using scripts

    Thanks again 

     

    0
    Comment actions Permalink
  • Avatar
    David Oyler

    Akshay - do you see the plugin listed in the Admin section? If you do, you can try disabling then re-enabling the plugin. If that doesnt work maybe try restarting the Sisense services. Last maybe a server reboot. If none of that works, you may want to get support involved.

    0
    Comment actions Permalink

Please sign in to leave a comment.