Jump to Dashboard Filter

Comments

7 comments

  • Avatar
    Adi Lewenstein

    Hi David!

    You can choose the filters you would like to pass on to the Jump To by defining them in the action's panelsToInclude property:

     

    Each panel that you would like to pass on as a filter should be defined with the panel name and the value you would like to pass. In the value, you can either use the panel's plain value using {panel:..} or {value:...} notation, or you can set a hardcoded value.

     

    Let me know if that helps.

    0
    Comment actions Permalink
  • Avatar
    David Oyler

    Hi Adi;

     

    That worked as long as I included the "includeFilterDims" parameter. Once I did that, none of the main dashboard filters were passed, which is fine, except that I do want to pass one of them. Is there a way to pass a specific filter from the Dashboard? The field that is in the filter is not part of the Blox widget as one of the panels. In the below shot, the Date.Date(Calendar) field is what I want to pass.

     

    0
    Comment actions Permalink
  • Avatar
    David Oyler

    Hi Adi - I think I got it figured out. Thank you.

    0
    Comment actions Permalink
  • Avatar
    Roopa Raghavan

    David Oyler,

    Can you explain how you got it to work. I have a few dashboard filters that I'd like to pass and can't get it to work with includefilterdims parameter.

    Thanks.

    0
    Comment actions Permalink
  • Avatar
    David Oyler

    Hi Roopa;

    This is what I am using. I have 2 filters on the main dashboard and the selections for those are passed into the dashboard I jump to. I'm unsure if the name of the filter needs to match what is entered in the includeFilterDims, but I have always made sure they matched.

    "actions": [
    {
    "type": "JTD",
    "style": {
    "font-size": "14px",
    "color": "#fa1b7c",
    "background-color": "#FFFFFF"
    },
    "title": "Site Ovt",
    "data": {
    "dashboardId": "5d433166554c930880137b36",
    "args": {
    "displayDashboardsPane": false,
    "displayFilterPane": false,
    "displayToolbarRow": false,
    "displayHeaderRow": false,
    "includeFilterDims": [
    "[Date.Date (Calendar)]",
    "[DimSiteOfService.Site Name]"
    ]
    }
    }
    }
    0
    Comment actions Permalink
  • Avatar
    Roopa Raghavan

    David thanks so much for your reply. I will update here on what's happening in my scenario in a short while.

    Thank you,
    Roopa

    0
    Comment actions Permalink
  • Avatar
    Roopa Raghavan

    David,

    I feel silly mentioning this - I had switched off some dashboard filters in the widget and didn't notice that and kept wondering why some dash filters weren't getting passed through. All works as expected now!

    Roopa

     

    0
    Comment actions Permalink

Please sign in to leave a comment.